Chromium se queda sin Flash Player en abril

Estándar

El Adobe Flash Plugin dejará de funcionar en Chromium en Abril

 

Como bien sabemos los usuarios de Linux, Chromium es la alternativa a Chrome, el navegador web de código abierto que sirve de base para el desarrollo de Google Chrome. En septiembre se anunció que tanto Chrome como Chromium ya no recibirán soporte de Netscape Plugin APIs (NPAPI) al finalizar el 2014 y soportarán las Pepper Plugin APIs (PPAPI), pero en el caso de Linux se van a adelantar y en abril Chromium abandonará las NPAPIs, entre las que se encuentra Adobe Flash Plugin.

Así a secas. Ya en setiembre anunciaron que tanto Chrome como Chromium le darán el adiós al soporte de Netscape Plugin APIs (NPAPI) para cuando acabe el 2014 y se dedicarán a soportar las Pepper Plugin APIs (PPAPI). Pero ahora se adelantarán para el caso de Linux. En abrilChromium abandonará las NPAPIs (entre ellas el Adobe Flash Plugin).

Ahora, ¿Por qué tanto apuro en Linux y no en Windows o Mac OS? Porque Chrome y Chromium 34 (que lo esperan para abril) en Linux va a venir con Aura, el stack gráfico que usan en Chrome OS y que lo llevarán a los otros sistemas operativos. No utiliza widgets nativos, cuenta con aceleración gráfica cuando está disponible y lo más importante: “dibuja” cada bit del navegador virtualmente, sin necesidad de usar GTK+ o Win32, lo cual significará una mayor unificación de su código base y la posibilidad de que su interfaz sea en verdad multi-plataforma. Con esto, Google llega a deshacerse un monton de APIs depreciadas, entre ellas las NPAPIs.

Y………..¿que alternativas tendrán los usuarios de Chromium en Linux? Dos nada másO instalar el Pepper Flash del Chrome, lo cual implica bajarse el Chrome, descomprimirlo, extraer el flash, colocarlo en /opt y borrar el chrome (no sólo hay un script para eso, sino que ya hay distros que empaquetan ese script. Ubuntu lo tiene en su Software Center, Arch lo tiene en el AUR y Debian lo incluye en sus repos contrib)…………… o no instalarlo y limitarse a usar lo que haya de HTML5.

Ah, y para los que usen Firefox, esto no les va a afectar porque sólo afecta a Chromium y sus derivados. Ya para Firefox 28 o 29 se espera Shumway. Yo ayer lo probé descargando la extensión, y va muy bien pero aún le falta.

(Tomado blog.desdelinux.net )